Deprecation of TLS 1.0/1.1

 

What is TLS?

Transport Layer Security (TLS) is a protocol that ensures privacy between communicating applications and their users on the internet.
When a server and client communicate, TLS ensures that no third party may eavesdrop or tamper with any message.
TLS is the successor to the Secure Sockets Layer (SSL).

[ top ]

 

What is changing?

On December 19th, 2017 the ability to utilize TLS 1.0 and TLS 1.1 encryption protocols as part of connecting to the ProntoForms service will be discontinued. As part of our commitment to security standards and to protect our clients’ security we continually look and act to ensure the integrity of our service. TLS versions other than 1.2 have been proven to be less secure as such pose a risk and are therefore not acceptable for the handling of sensitive traffic. ProntoForms will only be supporting TLS v1.2, any earlier versions will not be accepted.

[ top ]

 

What is the impact of this change?

This deprecation has the following impact on the ProntoForms service:

  • API integration connections using anything other than TLS v1.2 will no longer function
  • Older native applications will not be able to reconcile with the ProntoForms service
  • Web Browsers that are not up-to-date will be unable to access the ProntoForms portal

[ top ]

 

What action is required?

Mobile Apps

Ensure you are using a device which implements and supports TLS 1.2. Please review the following article for a list of the supported operating systems:
https://support.prontoforms.com/hc/en-us/articles/220378048-Supported-Operating-Systems-for-ProntoForms

Please note: that while Android 5.0 and above do have support for TLS 1.2, it's possible for customized (through a vendor or otherwise) versions of Android may disable this functionality. If you're not sure if your device supports TLS 1.2, there are services such as HowsMySSL.com which you can visit from a browser on the device to confirm the TLS version it supports. In the case of HowsMySSL.com, you would want to ensure that the following message is displayed:


Web Browsers

Updating your browser of choice to the following versions at a minimum will be required to prevent issues in accessing the ProntoForms portal:

Browser  Minimum Version
Internet Explorer  11
Chrome  30-32
Firefox 27–33 
ESR 31.0–31.2
Edge  12

API Integrations

Any API integrations which communicate with the ProntoForms service will need to be reviewed to ensure connections are made using TLS 1.2. Any connections to the ProntoForms service using anything other than TLS 1.2 will not be accepted.

[ top ]

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments